Measuring Mitochondrial Shape with ImageJ

Ronald A. Merrill, Kyle H. Flippo, and Stefan Strack

Abstract

Mitochondria are shaped by opposing fission (division) and fusion events. Mounting evidence indicates that mitochondrial shape influences numerous aspects of mitochondrial function, including ATP production, \( \text{Ca}^{2+} \) buffering, and quality control. Despite the recognized importance of mitochondrial dynamics, the literature is rife with subjective, categorical estimates of mitochondrial morphology, preventing reliable comparison of results between groups. This chapter describes stringent, but easily implemented methods for quantification of mitochondrial shape changes using the open-source software package ImageJ. While we provide examples for analysis of epifluorescence images of cultured primary neurons, these methods are easily generalized to other cell types and imaging techniques.

Key words ImageJ, Fiji, Microscopy, Mitochondrial fission/fusion, Morphometry, Digital image analysis

1 Introduction

The word mitochondrion derives from the Greek words for thread (mitos) and grain (khondros), hinting at the ability of mitochondria to assume diverse morphologies. Mitochondria can be spherical, rod-shaped, or even branched and highly interconnected, forming a “mitochondrial reticulum.” Reflecting their complex cytoarchitecture and the need for long-distance transport of mitochondria, neurons typically harbor mitochondria than span the entire shape spectrum. For instance, a serial section electron microscopy study documented branched mitochondria tens of microns in length in primary dendrites of hippocampal pyramidal neurons, while mitochondria in axon terminals were near spherical in shape [1].

Mitochondrial shape is determined by precisely orchestrated fission and fusion events. Fission, or division, followed by growth is how cells generate new mitochondria in response to increased energy demand or to replace damaged mitochondria. Fission is also intimately involved in programmed cell death, or apoptosis, facilitating cytochrome C release from the mitochondrial intermembrane space. In highly polarized cells, such as neurons, fission...
is prerequisite for transport of mitochondria. Fusion, on the other hand, allows for mixing of mitochondrial content and the formation of reticular mitochondrial networks, which are generally associated with increased calcium buffering and bioenergetic capacity [2, 3].

Not easily replaceable, torturous in shape, highly demanding for energy, and relying largely on oxidative phosphorylation for ATP production, neurons are particularly susceptible to an imbalance of mitochondrial fission and fusion. For instance, evidence is mounting that dysregulated mitochondrial dynamics may be causative for common neurodegenerative disorders, including Alzheimer’s and Parkinson’s disease [3]. Moreover, mutations in mitochondrial fusion enzymes can lead to hereditary neurological disorders. Mutations in optic atrophy 1 (Opa1), an enzyme involved in fusion of the inner mitochondrial membrane, causes autosomal dominant optic atrophy, the most common inherited cause of blindness [4]. Mutations in the outer-membrane fusion protein mitofusin-2 (Mfn2) are responsible for Charcot–Marie–Tooth disease type 2A, a common peripheral sensory and motor neuropathy [5]. On the fission side, the mitochondria-dividing enzyme dynamin-related protein 1 (Drp1) and mitochondrial fission factor (Mff), the receptor for Drp1 at the outer mitochondrial membrane, have been found mutated in several cases of severe birth defects, childhood epileptic encephalopathy, and early infant death [6–10].

The development and adoption of rigorous analytical methods has lagged behind the growing interest in the field of mitochondrial dynamics. Indeed, primary research articles that describe mitochondrial shape in subjective, categorical terms (e.g., percent of cells with normal, fragmented, or elongated mitochondria) continue to be published. Subjective shape scores may be difficult to compare between experimenters, can introduce bias, often lack sensitivity, and reduce the power of statistical analyses, all of which may lead to erroneous conclusions. Subjective scores do, however, have a place as benchmarks, i.e., when validating new image analysis algorithms. In this chapter, we briefly touch on methods for labeling mitochondria before introducing the reader to mitochondrial shape analysis (morphometry) using ImageJ. Available bundled with various add-ons (“plugins”) for life scientists as the Fiji distribution, ImageJ is an open-source, cross-platform application with powerful scripting capabilities that is continually improved by its user community [11]. ImageJ often outperforms commercial software solutions and facilitates increased reproducibility by providing transparent (open-source) data analysis for free. Our methods focus on single time point, “snapshots” of mitochondrial shape rather than counting individual fission and fusion events over time, as this allows the sampling of a larger population of neurons. Limited programming experience is helpful, but is not required to follow the code samples provided in this chapter. A simple, but fully functional macro for
mitochondrial morphometry is listed in Appendix and is available for download at http://imagejdocu.tudor.lu/.

2 Materials and Equipment

1. Primary neuronal cultures on 4-chamber cover glasses (No. 1 or 1.5, Nunc Lab-Tek or In Vitro Scientific).
2. Inverted epifluorescence or confocal microscope with 60, 63, or 100× oil-immersion lens.
4. Fiji (ImageJ distribution available at fiji.sc).
5. Computer running Windows, Mac OS, or Linux.

3 Methods

3.1 Labeling and Visualization of Mitochondria

All methods in this chapter involve primary, dissociated hippocampal or cortical cultures from embryonic rats or neonatal mice, but should be adaptable to other cell or tissue preparations. High-resolution images are key to accurate mitochondrial shape measurements. To permit the imaging of cultures using high-magnification (60–100×), low working-distance oil immersion lenses, neurons are cultured on a 4-chambered cover glass (e.g., Nunc Lab-Tek) coated with poly-L-lysine. We follow routine methods for preparing primary neuronal cultures that are described in detail elsewhere [12].

Mitochondria are readily visualized by fluorescence microscopy after labeling with mitochondria-targeted cationic dyes (e.g., MitoTracker, Rhodamine 123), with antibodies to mitochondrial antigens (e.g., cytochrome oxidase, Tom20) and fluorescent secondary antibodies, or by expression of mitochondria-targeted fluorescent proteins (FPs), such as GFP or mRFP. Mito-FPs and many cationic dyes can be visualized both in live cells and after fixation of the cultures with paraformaldehyde. Imaging fixed cultures is usually more convenient and may be the only option if autofluorescence of the culture medium overlaps with the emission of the fluorescent dye or protein.

We typically cotransfect neuronal cultures with a protein or shRNA of interest and a mito-FP in order to examine the impact of manipulating a specific fission/fusion enzyme, and its regulators, on mitochondrial shape. Compared to cationic dyes and immunofluorescence staining, mito-FP expression provides higher signal-to-noise ratios and eliminates interference by mitochondria of adjacent, non-transfected cells. We have had excellent success labeling the mitochondrial matrix with dsRed, EYFP, and
turboBFP fused to the N-terminus of cytochrome-oxidase subunit 8 (COX8, addgene # 58425). The outer mitochondrial membrane can be labeled with FP fusions of the N-termini of Mas70p (yeast TOM70) or AKAP1. We routinely achieve 5% transfection efficiency in younger cultures (2–5 days in vitro, DIV) using Lipofectamine 2000 (Invitrogen) in the following protocol. More mature cultures are most efficiently transfected using magnetic beads (MagnetoFection, Ozbiosciences) according to the manufacturer’s instructions.

**Protocol**: chemical transfection and preparation of primary neuronal cultures for imaging.

This protocol describes transfection of the four compartments of a 4-chambered cover glass with the same plasmid DNA (encoding for example mitochondria-targeted GFP). For convenience, plasmid stocks are prepared at 100 ng/μl in sterile buffer (10 mM Tris pH 8.0).

1. Mix 23 μl plasmid stock with 112 μl Opti-MEM, and in a separate tube mix 1.6 μl Lipofectamine 2000 with 133.4 μl Opti-MEM.
2. Incubate separately at room temperature for 5 min.
3. Meanwhile, carefully draw off culture medium from cover glass, add back 300 μl to each compartment, and save the rest of the conditioned medium at 4 °C.
4. Combine DNA and Lipofectamine dilutions and incubate at room temperature for 10–15 min.
5. Add 60 μl DNA–Lipofectamine mix to each cover glass chamber.
6. Incubate for 2–3 h. in tissue culture incubator (37 °C, 5% CO₂).
7. To the remainder of the conditioned medium from step 3, add fresh medium to 2.2 ml and warm to 37 °C.
8. Aspirate off transfection mix and replace with 0.5 ml conditioned/fresh medium per chamber.
9. After 2–5 days, proceed to live imaging or fix as follows:
10. Add 0.5 ml 8% paraformaldehyde in phosphate-buffered saline (PBS) to each chamber (final concentration 4%). If cultures are to be imaged without prior immunofluorescence staining, nuclei can be counterstained during this step by adding Hoechst 33342 (2 μg/ml) to the fixative.
11. Incubate for 15 min at 37 °C.
12. Wash 5–6 times with PBS; add 0.5 ml PBS/chamber after last wash.
13. Proceed with imaging after optional immunofluorescence labeling.
Options for immunofluorescence include FP-directed antibody/fluorescent secondary antibody combinations to boost intrinsic fluorescence, or MAP2B, β3-tubulin, or NeuN to positively identify neurons. Nuclei are conveniently stained during incubation with fluorescent secondary antibodies; DAPI, Hoechst, or TO-PRO3 is used depending on channel availability. Wide-field epifluorescence or confocal images are captured at maximum resolution (no binning) and using 60–100× oil immersion lenses. While we typically capture single images of the neuron soma and proximal dendrites, it is also possible to capture the entire neuronal arbor at high resolution by merging overlapping images using ImageJ’s “stitching” function (Plugins ▸ Stitching). Generally, between 30 and 60 images per experimental condition are sufficient to detect moderate effects.

It is near impossible to obtain reliable morphometric data from marginal images, so neuronal culturing, mitochondria labeling, and image acquisition should be optimized for best results. Optimizations include but are not limited to:

1. Assuring complete dissociation of the tissue and plating cells at a density appropriate for a particular mitochondria labeling technique, e.g., mitochondria labeled with cationic dyes or antibodies are best imaged in sparsely seeded cultures.

2. Minimizing temperature fluctuations, fluid shear, and other neuronal stressors that could artifactually impact mitochondrial morphology.

3. Adjusting dye and antibody concentration, incubation times, and wash and fixation conditions, and minimizing the time between labeling and imaging.

4. Adjusting imaging settings (light intensity, exposure time, focus, pinhole diameter, detector gain and offset) to minimize noise and to use the full range of pixel intensities without saturating the image.

Measuring mitochondrial shape with ImageJ requires transforming grayscale or RGB images into binary (black and white) images to define objects and background. This digitization process, referred to as segmentation or thresholding, invariably entails loss of information. Filtering or preprocessing can reduce this information loss to improve morphometric data obtained from even high quality images. Improvements may be evident as a decrease in variability within an experimental group, an increase in effect size between groups, or both. ImageJ/Fiji implements a variety of image filters that are useful to this end, including noise reduction, background subtraction, and contrast and feature enhancement filters. Particularly useful prior to mitochondrial shape analyses are:

3.2 Image Preprocessing
(a) **Process ▶ Subtract Background.** This filter removes smooth and continuous, including unevenly illuminated backgrounds using a “rolling ball” algorithm [13]. The “Rolling Ball Radius” is an important parameter as it partitions the image into foreground and background. For 8-bit or RGB images, it should be larger than the largest object in the image. For a 1392 x 1040 pixel image of mitochondria imaged with a 100× objective, a radius of 50 works well.

(b) **Process ▶ Noise ▶ Despeckle.** As the name implies, this filter removes granular noise from the image. It replaces each pixel with the median value of its 3 × 3 neighborhood and is particularly helpful when analyzing confocal images acquired with high detector gain.

(c) **Process ▶ Enhance Local Contrast (CLAHE).** Mitochondria are often unevenly labeled, so that weakly labeled parts of mitochondria may be lost after segmentation. Contrast-limited histogram equalization, or CLAHE, mitigates this problem by dividing an image into small squares, or tiles, each of which is contrast-enhanced separately. Bilinear interpolation then eliminates edge artifacts between tiles. The parameter “blocksize” specifies the size of the tiles in pixels, while “maximum slope” limits the contrast stretch during intensity transfer (“1” retains the original image). A combination of blocksize = 9 and slope = 4 results in an aggressively enhanced image that loses little information after segmentation.

(d) **Tubeness and Vesselness (Plugins ▶ Analyze ▶ Tubeness and Plugins ▶ Process ▶ Frangi Vesselness).** These two Hessian matrix-based filters are object-aware and were originally developed to enhance images of blood vessels [14, 15]. However, they also detect other tubular structures such as mitochondria or neurites. At the time of this writing, the Frangi Vesselness implementation is still experimental, so we will limit our discussion to the Tubeness filter. The “Sigma” parameter tunes the filter to detect thinner or thicker mitochondria. Processing an uncalibrated image, a value of 3 (pixels) yields acceptable results.

(e) **Process ▶ FFT ▶ Bandpass Filter.** This filter performs a fast Fourier transform (FFT) followed by Gaussian filtering of the power spectrum. As a bandpass filter, it can remove both small and large objects, filtering noise and uneven background in one step. Unique to this filter, the “Suppress stripes” option removes horizontal or vertical lines by masking frequency components near the coordinate axes of the power spectrum.

Figure 1 illustrates the effects of CLAHE and Tubeness filters on an epifluorescence image of a hippocampal pyramidal neuron expressing mitochondria-targeted GFP. Exposure was adjusted for
optimal imaging of dendritic mitochondria, which leaves those in the cell body slightly overexposed. The left column shows 8-bit grayscale images pseudo-colored using the “Fire” color lookup table (Image > Lookup Tables > Fire). The right column shows the corresponding binary images obtained by thresholding according to ImageJ’s default method (Process > Binary > Make Binary). Thresholding the original image eliminates most mitochondria in dendrites and renders mitochondria in the cell body as an indistinct mass.

Processing the original image by CLAHE with a block size of 9 and maximum slope of 4 dramatically improves the binary image such that it now visually approximates the original, unprocessed image. Local contrast enhancement retains peripheral mitochondria and at least partially resolves overlapping mitochondria in the soma. The Tubeness filter accentuates isolated mitochondria even more and strongly suppresses the mass of overlapping mitochondria in the soma. In this example, both CLAHE and Tubeness filters were preceded by rolling-ball background subtraction (radius 50)
with optional smoothing enabled. This step suppresses artifacts resulting from enhancement of noise and background.

The next step after experimenting with and settling on a combination of filters is to automate image preprocessing. There are several ways to do this with ImageJ. For instance, calls to these filters can be encapsulated in a “wrapper” script (or macro) that processes all images in a folder. A template for such a wrapper is generated by opening a new macro window (Plugins ► New ► Macro) and then selecting from the macro editor window the Process Folder template (Templates ► IJ1 Macro ► Process Folder). A second option is to save the filter commands as a text file and then invoke Process ► Multiple Image Processor. A similar option is Process ► Batch ► Macro, which opens a text window that allows direct pasting of the filter commands. The actual filter commands are generated using ImageJ’s command recorder (Plugins ► Macro ► Record). By way of an example, the following command sequence was recorded while generating the CLAHE-enhanced grayscale image in Fig. 1:

```
run("Subtract Background...", "rolling=50");
run("Enhance Local Contrast (CLAHE)", "block-size=9 maximum=4 mask=*None*");
run("Fire");
```

Changing the filter parameters is now as easy as editing the commands. A more explicit way to change parameters is to define them as variables:

```
rollingBall = 50; // radius.
blockSize = 9; // 3x3 tile size.
slope = 4; // contrast stretch limit.
run("Subtract Background...", "rolling=" + rollingBall);
run("Enhance Local Contrast (CLAHE)", "block-size=" + blockSize + " maximum=" + slope + " mask=*None*");
run("Fire"); // pseudocolor the image
```

Voila, you have written your first ImageJ macro! The two slashes start an in-line comment; multi-line comments are bracketed with /* and */. This may be familiar, because ImageJ’s macro language is based on JavaScript, which in turn borrows its syntax from the classic C programming language.

### 3.3 Morphometry

Now that our images have been cleaned up, we can proceed to measuring the size of mitochondria. A simple macro for this task is listed in Appendix as “morphometry.” At the core of the macro is ImageJ’s Analyze ► Analyze Particles… command, which takes as input a binary image and compiles a table of measurements containing one row per particle (Results window). The remainder
of the macro prepares the image for analysis by cropping to the selected region-of-interest (ROI), blanking the area outside of the selection, and thresholding. Overexposed areas (often the cell body in epifluorescence images) need to be excluded from the ROI. After the call to Analyze Particles, the macro extracts values from the Results window to compute composite measurements and averages for the ROI. The macro encourages experimentation with different preprocessing filters and thresholding methods (see also Image ▶ Adjust ▶ Auto Threshold) by including automated analysis in batch mode (more on this below). Figure 2 summarizes the shape descriptor output of the morphometry macro.

**Fig. 2** Mitochondrial shape descriptors. (a) Definition of shape metrics generated by the morphometry macro in Appendix. Average metrics are calculated from area, perimeter, major and minor axis of an elliptical fit of binary particles, and area after skeletonizing the binary particles. (b) metrics obtained from binary images before (a) and after (b) two simulated fission events
These five descriptors were culled from a larger list of descriptors as those that most reliably reflect changes in the mitochondrial fission/fusion equilibrium:

1. *Area* is computed by summing the squared areas of each particle and dividing by the square of the summed areas. This is essentially a measure of the average size of mitochondria weighted towards larger mitochondria.

2. *Form factor* also takes into account the mitochondrion’s perimeter. As the inverse of circularity, it describes a particle’s shape complexity. Its minimum value is 1 for a perfect circle. Form factor is a frequently reported mitochondrial shape metric that is particularly reliable for well-separated mitochondria. As noise and out-of-focus areas can artifactually increase an object’s perimeter, form factor is very sensitive to image quality and is generally not applicable without pre-filtering the image.

3. *Area-weighted form factor* is a variant of form factor that averages across the ROI with a bias towards larger mitochondria or mitochondrial networks. Similar to area, it provides more credible results in cases where highly elongated mitochondria are overlapping and therefore cannot be resolved. It also has a minimum value of 1, but produces larger, more variable averages than form factor (Fig. 2b).

4. *Aspect ratio* is independent of area and perimeter. It is defined as the ratio of the major and short axis of an ellipse fit to an object, and therefore also has a minimum value of 1 (Fig. 2a). Since bending an oblong object decreases its aspect ratio, this descriptor is primarily recommended for well separated, rod-shaped mitochondria in axons and dendrites. Because it does not consider perimeter, the aspect ratio is relatively insensitive to image quality.

5. *Length*, reported in units of pixels or microns (for calibrated images), is the most intuitive of the shape descriptors. Unfortunately, it is also the least forgiving in that it requires high quality images of nonoverlapping mitochondria. This descriptor benefits from preprocessing with shape-aware filters such as Tubeness and Vesselness, which produce mitochondria of uniform width while filtering out clumps. Length is independent of area, perimeter, and major and minor axis. In fact, it is not even derived from the binary representation that gives rise to the other shape descriptors. Instead, length is computed by “skeletonizing” the binary image (Process ▶ Binary ▶ Skeletonize), reducing mitochondria to single-pixel-wide shapes. Length is then simply the average area (number of pixels) of these skeletons.

The morphometry macro also outputs the number of particles in the ROI (n), which may be useful in documenting fission and
fusion events in a time lapse series. How do you interpret the mac-
ro’s results and which descriptors do you report? We conclude that
mitochondrial morphology has changed if (a) at least three of the
five metrics show significant differences and if the other two at least
trend in the same direction, (b) at a minimum trends are apparent
when analyzing raw, unfiltered images, and (c) changes are readily
apparent to a blinded observer. As mentioned before, visual inspec-
tion combined with some kind of categorical scoring is an impor-
tant benchmark, especially when setting up mitochondrial
morphometry for the first time. When presenting or publishing
results, showing two independent shape measures adds credibil-
ty to your interpretations. Area², form factor, and area-weighted form
factor have parameters in common, but aspect ratio and length are
derived independently. As shown for aspect ratio and form factor in
Fig. 3a, representing two independent metrics as an XY plot is par-
ticularly convincing if the data points fall on a straight line.

4 Results

Figure 3 illustrates the impact that filtering images prior to shape
analysis has on the quality of the data. For this experiment, primary
rat hippocamal cultures were transfected with wild-type or
dominant-negative mitochondrial fission factor (Mff), the principal
receptor for Drp1 at the outer-mitochondrial membrane.
Mitochondrial RFP was co-transfected to label mitochondria.
Images of fixed neurons (60/condition) were acquired using the
100× lens of an epifluorescence microscope. Neurons were out-
lined, avoiding the overlapping and overexposed mitochondria in
the cell body (Fig. 3a).

Analysis of raw images shows small trends towards increased
fission upon overexpression and decreased fission upon dominant-
negative inhibition of Mff in comparison to neurons expressing
outer mitochondrial GFP. Local contrast enhancement (CLAHE)
alone or CLAHE followed by the Tubeness filter increases the
effect size as well as the significance of manipulating Drp1 recruit-
ment to mitochondria. Tubeness by itself results in only dominant-
negative inhibition of Mff reaching statistical significance.

The choice of thresholding algorithm also has an impact on
data quality. The morphometry macro calls the default algorithm
(Process▶ Binary▶ Make Binary). However, there are 15 alternative
methods available in the Fiji distribution under (Image▶ Adjust▶
Auto Threshold). Of those, the “Li” and “Otsu” algorithms have
been found to be superior to the default under some conditions.

This example highlights the importance of choosing an opti-
mal combination of preprocessing and thresholding methods. To
simplify this process, the morphometry macro can be run in batch
mode (“Batch Morphometry [F8]”), applying a set of previously
saved ROIs to a new set of images (or to the same images but using a different threshold method). With this feature, cells have to be outlined only once as long as the content of the ROI manager is saved after all images in a folder have been analyzed (Window ▶ ROI Manager ▶ More ▶ Save).

5 Conclusions

Mitochondrial dynamics is now well recognized as an important determinant of mitochondrial function, with disturbances of the mitochondrial fission/fusion equilibrium resulting first in neurological disorders. There is no reason that mitochondrial morphology should be investigated less rigorously and less quantitatively than respiration, ROS production, or any other aspect of mitochondrial function covered in this volume. ImageJ, an open-source environment supported by a large community of scientists, provides a platform for transparent image processing and analysis. ImageJ’s command recorder and macro language enables scientists...
without programming experience to automate complex workflows. We hope that this chapter convinces the reader that fluorescence microscopy is compatible with exact science. Further, we hope to provide inspiration to automate other types of image analysis such as densitometry and colocalization.

Acknowledgments

This work is currently supported by NIH grants NS056244 and NS087908 to S.S. We thank past and present members of the laboratory for providing critical feedback for development of the methods described in this chapter.

6 Appendix—Morphometry Macro

```javascript
var ch = 0; // channel to be analyzed for RGB images

/*
* Measure mitochondrial morphology in the current selection
* Ctrl+Shift+O closes current and opens next image
*/

macro "Morphometry [F7]" {
  title = getTitle();
  morphometry(title, false); // not batch mode
}

/*
* Batch-apply a set of "named" ROIs to analyze images with that file name
*/

macro "Batch Morphometry [F8]" {
  dir = getDirectory("Select an image directory");
  while (roiManager("Count") == 0)
    waitForUser("Please open named ROIs into ROI manager");
  prevName = imgName = "";
```
n = roiManager("Count");
for (i = 0; i < n; ++i) { // loop through the ROI Manager table
    prevName = imgName;
    imgName = call("ij.plugin.frame.RoiManager.getName", i);
    if (isOpen(imgName)) { // named image is open
        selectWindow(imgName);
    } else { // done with current image, close and open next
        if (isOpen(prevName)) {
            selectWindow(prevName);
            close();
        } open(dir + imgName);
    }
    roiManager("Select", i);
    morphometry(imgName, true); // batch mode
}

function morphometry(title, batchMode) {
    while (ch < 1 || ch > 3) { /* RGB channel not yet selected, initialize; reinstall macro to change channel */
        ch = getNumber("Analyze RGB channel(1-3):", 1);
        run("Set Measurements...", "decimal=5 area perimeter fit");
        print("image	 n	 area2	 area-weighted ff	 form factor	 aspect ratio	 length"); /* header for results table */
    }
    if (bitDepth == 24) // RGB image
        run("Make Composite");
    if (isOpen("Binary")) {
selectWindow("Binary");
close();
} // close previous working image
if (isOpen("Skeleton")) {
    selectWindow("Skeleton");
close();
} // close previous working image
selectWindow(title);
if (selectionType() == -1) // no selection
    run("Select All");
if (!batchMode) {
    roiManager("Add"); // save selection to ROI Manager for batch processing
    last = roiManager("Count") - 1;
    roiManager("Select", last);
    roiManager("Rename", title);
    /* roiManager("Save", File.directory + "named_ROIs.zip"); */ /* un-comment to save ROIs automatically */
}
// copy selection to new window and clear outside
setSlice(ch); // ignored if grayscale
run("Duplicate...", "title=Binary");
run("Make Inverse");
if (selectionType != -1) { // outside of ROI is selected
    run("Duplicate...", " "); // make a mask of the background
    run("Convert to Mask");
    run("Create Selection");
    run("Make Inverse");
    roiManager("Add");
close();
n = roiManager("Count");
roiManager("Select", n - 1);
getRawStatistics(_area, backG); // mean is background
setColor(backG);
run("Restore Selection"); // fill outside of selection with background
fill();
run("Gaussian Blur...", "radius=64"); // smooth abrupt background transition
roiManager("Delete"); /* delete masking selection (ROI manager has cell selections) */
}
run("Select None");
// subtract background and threshold
run("Subtract Background...", "rolling=50"); /* non-destructive filter even if already applied */
run("Make Binary");
// also try other threshold methods included with Fiji, e.g.: run("Auto Threshold", "method=Li white");
// create Results table of metrics, one line/particle
run("Analyze Particles...", "size=9-Infinity circularity=0.00-1.00 show=Masks pixel clear");
awff = ff = ar = sum_a = a2 = len = 0;
for (i = 0; i < nResults; i++) { // for every particle in table
  a = getResult("Area", i);
  p = getResult("Perim.", i);
  ar += getResult("Major", i) / getResult("Minor", i); /* aspect ratio = length / width */
  sum_a += a;
  a2 += a * a; // area2 = a2 / (sum_a * sum_a)
awff += b = (p * p) / (4 * 3.14159265358979); // awff = ff * (a / sum_area)
ff += b / a; // ff = p^2 / (4 * pi * a)
}

nParticles = nResults;
// skeletonize to get length
selectWindow("Mask of Binary"); /* created by Analyze Particles .., excludes noise (< 9 pixels) */
rename("Skeleton");
run("Skeletonize");
run("Analyze Particles...", "size=0-Infinity show=Nothing pixel clear");
for (i = 0; i < nResults; i++)
    len += getResult("Area", i);
// average and output
a2 /= sum_a * sum_a;
awff /= sum_a;
ff /= nParticles;
ar /= nParticles;
len /= nResults;
print(title + "	" + nParticles + "	" + a2 + "	" + awff + "	" + ff + "	" + ar + "	" + len);
selectWindow(title);

References


Techniques to Investigate Mitochondrial Function in Neurons
Strack, S.; Usachev, Y.M. (Eds.)
2017, XV, 344 p. 74 illus., 51 illus. in color., Hardcover
ISBN: 978-1-4939-6888-6
A product of Humana Press